`
richard_ma
  • 浏览: 15143 次
最近访客 更多访客>>
社区版块
存档分类
最新评论

poj1163 树型结构动态规划和最大路径

阅读更多
The Triangle

http://poj.org/problem?id=1163
http://acm.hdu.edu.cn/showproblem.php?pid=2084

Description
7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output
Your program is to write to standard output. The highest sum is written as an integer.

Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

Source
IOI 1994

这是一个树型结构的路径选择问题,要求选择出的路径和最大。很明显这里不能使用贪心策略,因为某一步的最大值可能影响后面的路径选择,而在后续的路径中求和“吃亏”。所以应该使用动态规划。

自底向上,每个数字对应的可能路径为2个,比较这两个路径的和,选择大的加上本节点的值,作为本节点的值(前驱节点的和)。

最终第一个元素的值就是最大路径求得的和。

#include <stdio.h>
#include <stdlib.h>

int main (int argc, char const* argv[])
{
    int i, j, n, a[100][100];

    scanf("%d", &n);
    for (i = 0; i < n; i++) {
        for (j = 0; j <= i; j++) {
            scanf("%d", &a[i][j]);
        }
    }

    for (i = n-2; i >= 0; i--) {
        for (j = 0; j <= i; j++) {
            a[i][j] += a[i+1][j] > a[i+1][j+1] ? a[i+1][j] : a[i+1][j+1];
        }
    }

    printf("%d\n", a[0][0]);

    return 0;
}
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics